Reports of some users unable to be removed from workspace
Incident Report for Notion
Resolved
The issue has now been resolved, users should now be able to remove users from their workspaces again.
Posted May 02, 2024 - 20:48 PDT
Investigating
We are currently experiencing an issues whereby some members are unable to be removed from their workspace. We are investigating the issue and will update shortly.
Posted May 02, 2024 - 20:30 PDT
This incident affected: Login and user accounts.