We are currently investigating an issue where duplicating a Notion site does not complete as expected.

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 22:59 PST

Update

We are continuing to investigate this issue.
Posted Dec 11, 2025 - 21:13 PST

Investigating

Some users may find that duplicating a Notion site appears to load but the duplicated page doesn’t show in the sidebar or anywhere in the workspace.
We’re investigating and will share an update once it’s resolved. Thank you for your patience.
Posted Dec 11, 2025 - 21:12 PST
This incident affected: Notion Sites.