Database Performance Issues
Incident Report for Notion
Resolved
This incident has been resolved.

Time of incident was approximately from 5pm PDT - 6pm PDT.
Posted Jan 04, 2024 - 18:06 PST
Investigating
We are experiencing latency issues with our collections service, so users may experience issues loading databases.

We're actively looking into this, and we'll provide updates when we get more information.
Posted Jan 04, 2024 - 17:32 PST
This incident affected: Notion App.