Forms view creation in existing database view is down, our team is investigating the issue.

Incident Report for Notion

Resolved

The issue has been resolved, and users can now add forms to the existing database views.
Posted Apr 29, 2025 - 08:44 PDT

Investigating

Our engineering team is investigating the issue.
Posted Apr 29, 2025 - 04:50 PDT
This incident affected: Notion App.